Got a powell!

Mini Bike & Go-Kart Parts

This project stalled a few years ago and this week I resumed working on it. Got the wheels finished and assembled, painted the front end I made and fit it all together (thanks to Havasu Dave for his detailed drawings of the guts of the front end as I could not remember how it went together) finished painting the rest of the bike yesterday. Waiting for the paint to harden good and time to assemble it. I did add bearing spacers between the wheel bearings even though the Powell design does not put side pressure on them.
 

Attachments

I was away driving all over the east coast, Tenn and Alabama. Have been making slow progress on the powell since I arrived home last week. I have run into a few issues with the pulley and idler I made the frame for. The original had the idler axle welded to the frame and I used a bolt so as to make it replaceable. Well after assemble the bolt hits the frame preventing the idler from dropping down all the way. I cut the head off and welded it to one side but the nut on the threaded end still hits. It should still function OK but limit the max operation of the 20 series driver. Working on the led lighting system now and maybe today test run the engine on my engine stand.
 

Attachments

I74

Well-Known Member
I was away driving all over the east coast, Tenn and Alabama. Have been making slow progress on the powell since I arrived home last week. I have run into a few issues with the pulley and idler I made the frame for. The original had the idler axle welded to the frame and I used a bolt so as to make it replaceable. Well after assemble the bolt hits the frame preventing the idler from dropping down all the way. I cut the head off and welded it to one side but the nut on the threaded end still hits. It should still function OK but limit the max operation of the 20 series driver. Working on the led lighting system now and maybe today test run the engine on my engine stand.
Pretty wild looking exhaust there.. Would like to know & see more details of that. :cool:
 
getting ready to install engine. Test ran it yesterday got carb adjusted and it runs well. Alternator output verified and now need to get 1/4-28 bolts for the pull starter. I also found the correct metal gas tank on ebay and am waiting for that to come so I can paint it and install it on the motor. I can't seem to upload a .AVI file to see engine running. How do I upload a video file?
 

Attachments

Top